Wednesday, 3 April 2013

Plesk 9 installer fails while 11 works fine, Plesk 9 going EOL

So I wanted to test Plesk 9 to 10 to 11 upgrade, created new server and... failed to load Plesk 9.

Fresh Centos 5.9 Cloud Server, 1GB RAM, 40GB HDD

[root@plesk ~]# cat /etc/redhat-release
CentOS release 5.9 (Final)
[root@plesk ~]# uname -a
Linux plesk 2.6.18-348.3.1.el5xen #1 SMP Mon Mar 11 20:28:48 EDT 2013 x86_64 x86_64 x86_64 GNU/Linux
[root@plesk ~]# free -m
             total       used       free     shared    buffers     cached
Mem:          1024        157        866          0          5         39
-/+ buffers/cache:        113        910
Swap:          976          0        976
[root@plesk ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/xvda1             39G  1.2G   36G   4% /
tmpfs                 512M     0  512M   0% /dev/shm
[root@plesk ~]#

Plesk 9 installer - http://www.parallels.com/uk/download/plesk9/ , pick CentOS, Download for CentOS 5.x 64bit version, direct link -  http://download1.parallels.com/Plesk/PPP9/CentOS5/parallels_installer_v3.6.0_build100407.15_os_CentOS_5_x86_64

On "Select the desired products and their versions" page I've tried 11.0.9, 10.4.4 and 9.5.4 all got stuck with the following error message.

Select the desired products and their versions
===============================================================================

The following product versions are available:

1. [*] Parallels Plesk Panel
  2. (*) Parallels Plesk Panel 11.0.9 (stable)
  3. ( ) Parallels Plesk Panel 10.4.4 (stable)
  4. ( ) Parallels Plesk Panel 10.3.1
  5. ( ) Parallels Plesk Panel 10.3.0
  6. ( ) Parallels Plesk Panel 10.2.0
  7. ( ) Parallels Plesk Panel 10.1.1
  8. ( ) Parallels Plesk Panel 10.1.0
  9. ( ) Parallels Plesk Panel 10.0.1
  10. ( ) Parallels Plesk Panel 10.0.0
  11. ( ) Parallels Plesk Panel 9.5.4
  12. ( ) Parallels Plesk Panel 9.5.3
  13. ( ) Parallels Plesk Panel 9.5.2
  14. ( ) Parallels Plesk Panel 9.5.1
  15. ( ) Parallels Plesk Panel 9.5.0
  16. ( ) Parallels Plesk Panel 9.3.0
  17. ( ) Parallels Plesk Panel 9.2.3
  18. ( ) Parallels Plesk Panel 9.2.2
  19. ( ) Parallels Plesk Panel 9.2.1
  20. ( ) Parallels Plesk Panel 9.2.0
  21. ( ) Parallels Plesk Panel 9.0.1
  22. ( ) Parallels Plesk Panel 9.0.0
  23. ( ) Plesk 8.6.0
  24. ( ) Plesk 8.4.1
  25. ( ) Plesk 8.4.0
  26. ( ) Plesk 8.3.0
  27. ( ) Plesk 8.2.1
  28. ( ) Plesk 8.2.0

29. [ ] Parallels Small Business Panel

30. [ ] Sitebuilder 4.5 and earlier versions (for Plesk 9 and earlier)

31. [ ] SSO

N) Go to the next page; P) Go to the previous page; Q) Cancel installing
To select a version, type the respective number;
Select an action [N]:
File downloading PSA_11.0.9/plesk-11.0.9-cos5-x86_64.inf3: 11%..22%..30%..44%..55%..60%..72%..85%..90%..100% was finished.
ERROR: The root element is named incorrectly in the file /root/parallels/PSA_11.0.9/plesk-11.0.9-cos5-x86_64.inf3
Not all packages were installed.
Please, contact product technical support.
[root@plesk ~]#


Plesk 11 installer - http://www.parallels.com/uk/download/plesk/installer/, pick CentOS, Download for CentOS 5.x 64bit version, direct link -  http://download1.parallels.com/Plesk/PP11/11.0/CentOS5/parallels_installer_v3.12.0_build120601.16_os_CentOS_5_x86_64

Please note the date difference between both packages!

[root@plesk ~]# pwd
/root
[root@plesk ~]# ls -ltr
total 15852
-rwxr-xr-x 1 root root 6592768 Dec 21  2010 parallels_installer_v3.6.0_build100407.15_os_CentOS_5_x86_64
-rwxr-xr-x 1 root root 9592224 Jun  1  2012 parallels_installer_v3.12.0_build120601.16_os_CentOS_5_x86_64
drwxr-xr-x 5 root root    4096 Apr  3 11:34 parallels
[root@plesk ~]#

No issues with the installation when installer for version 11 is used.

Select the desired products and their versions
===============================================================================

The following product versions are available:

1. [*] Parallels Plesk Panel
  2. (*) Parallels Plesk Panel 11.0.9 (stable)

3. [ ] Parallels Small Business Panel

4. [ ] Sitebuilder 4.5 and earlier versions (for Plesk 9 and earlier)

5. [ ] SSO

N) Go to the next page; P) Go to the previous page; Q) Cancel installing
To select a version, type the respective number;
Select an action [N]:

AFTER SOME TIME

**** Package phpmyadmin scriptlet completed successfully.

Trying to unpack billing fixes from MU43-billing.zip... billing not installed. Skipping...
Patches were installed successfully.
The changes were applied successfully.

[root@plesk ~]# cat /usr/local/psa/version 
11.0.9 CentOS 5 110120608.16
[root@plesk ~]# 

Message is clear, Plesk 9 is so EOL! - http://www.parallels.com/uk/plesk/lifecycle/

1 comment:

Blogger said...

Bluehost is ultimately one of the best web-hosting company with plans for any hosting requirements.